
 

Internet Native Banner 

What is Internet Native Banner? 
Internet Native Banner (INB) is a browser-based application, accessible using Internet 
Explorer. 
 
To access Banner from off-campus, a VPN connection is required.  Please contact ITS at 
953-HELP (or helpdesk@citadel.edu) for technical assistance. 
 
Logging into INB 
 

1. INB can be accessed from the Finance Tab in Lesesne Gateway 
(https://lesesnegateway.citadel.edu)  

 

 
 

 
 
Note: Banner will need to install a Java applet,”plug-in”, the first time you access INB. 
If prompted, accept to install the Active X controls. 
 

2. Enter your campus user name in the Username field. 
 

3. Enter your Banner password in the Password field and click the Connect button.  
 

 
 

Note: If you do not know your Banner password, contact the Help Desk at 953-HELP.  
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Changing Banner Password 
 
1. From the Main Menu, click the Change Banner Password link.  
 

 
 
 
 
2. The Oracle Password Change Form (GUAPSWD) opens.  
 

 
 
3. In the Oracle Password field, type in your current password.  

• The Database field is not used.  

4. In the New Oracle Password field, enter your new password.  

5. In the Verify Password field, re-enter your new password.  

6. Click the Save  icon to save the new password and return to the Main Menu.  
 
Banner Main Menu 
 
Menus, forms, and modules are selected from the General Menu (GUAGMNU).  
 
1. From the General Menu screen, identify the various features by comparing your 
screen with the one shown below.  



 
 
 

FEATURE  DESCRIPTION  
Form Title Bar  Provides information about the active 

screen and window.  
Text Menu Bar  Provides access to pull-down menus.  
Icon Toolbar  Set of icons that represent shortcut 

functions available in the form. Icons 
grayed out are not available within the 
active form. The black X at the end of 
the Toolbar is used to exit the active 
form.  

Directory Tree  Shows the hierarchy of forms available 
in Banner. Double clicking on each 
folder opens the folder to the next 
level.  

Auto Hints  Provides information such as the 
current field the cursor is in, error and 
processing messages, how to access 
another window or form, next step, 
and field purpose. The record counter 



is also located in this section. The 
record counter shows which record is 
being viewed and how many records 
are available to view.  

Personalized Links Provides easy access to links used to 
change a Banner Password, check 
Banner Messages, and create 
customized links to other URLs.  
 

 
Banner Forms 
 
A Form is the Oracle term for one or more connected screens; each form name is also 
referred to as an object. Banner forms are “online documents” used to enter and/or 
look up information. 
 
The ability to view, access, and edit forms depends on the user’s security access level. 
 

 
 
 
 
 
 



Inside a Form 
 

 
 
FEATURE  DESCRIPTION  
Title Bar A Title Bar displays the form name and 

description of the form. 
Key Block  Data is entered in a key block to 

retrieve specific information.  
Information Block  An Information Block displays the 

information the key block has 
requested. The type of information 
displayed is determined by the form 
used and relevant to which module is 
active.  

Fields  A Field is a labeled space within a 
block. Information can be edited, 
queried, or displayed within a field. A 
drop-down or List of Values (LOV) can 
also be associated with fields.  

Record(s)  Information grouped together is called 
a Record.  

 



Navigating a Form 
 
When a form is accessed, there are several icons and keys available for navigating in the 
form. The following keys on the Toolbar are used to navigate within a form. 
 
Toolbar 
 
Like standard application interfaces, INB uses iconic (picture) buttons on the Toolbar to 
perform common actions. A bubble describing the function appears if the cursor is 
“paused” over an icon – rest your cursor on each picture on the Toolbar, paying 
particular attention to the icons on the left half of the line.  
 

 
 
KEY  FUNCTION  
Next Block  This key is used to move forward to the 

next block in a form. It is used to 
navigate from the Key Block to the 
Information Block and within sections 
(i.e. Tabs) of the Information Block. 
This is the most commonly used key.  

Previous Block  Moves back to the previous block of 
information and is used to move from 
the Information Block back to the Key 
Block to enter new search criteria.  

Rollback  Returns the emphasis to the Key Block 
and removes data displayed in the 
Information Block.  

Enter Query  Initiates the query function and allows 
search criteria to be entered.  

Execute Query  Performs the query search using the 
criteria entered. 

Exit Query  Clears the query and search results. 
 
 
 
 
 



The Status Bar 
 
The Status Bar at the bottom of each Banner form window reveals information on a 
pending function, indications of the data needed in a particular field, and any error 
messages. 
 

 
 
Menu Bars 
 
A Menu Bar containing pull-down menus is located at the top of every form. For 
example, press the Alt key to reach the Menu Bar, or place your mouse over File. 

 
1. Click on the File menu item, just as you would in any Windows environment. 

 
2. Click the File menu again and select Exit to return to the General Menu. 

 
3. The File Menu will also display up to 10 most recently viewed forms in the current 
session at the bottom of the File menu. This is an easy way to navigate back to a 
recently viewed form. 
 

 
 
 
 
 
 
 



Blocks 
 
Banner forms contain one or more blocks – a block is a framed portion used for a 
specific function (also called a “window”). If a form contains more than one block, the 
top one is a key block that determines criteria for displaying and/or entering 
information related to this form. 
 
There are multiple ways to navigate between blocks: 
 
Click the Next Block icon on the Toolbar 
 

  
 
Select Next from the Block pull-down menu 
 

 
 
Simultaneously press the CTRL and Page-Down keys. 
 
Different Ways of Accessing a Form 
 
Using its Name: 
 
You can reach the Organization Budget Status [FGIBDST] form by selecting it from the 
Banner -> Financial -> General Ledger -> General Accounting Query Forms -> General 
Budget Query Forms menu; or by selecting it from the File Menu’s recently viewed forms 
listing; or you could also directly access that form by knowing its object name. 
 
In the main GUAGMNU form click in the Go To field and key in the letters FGIBDST and 
press enter to access the form. 
 

 
 
But I don’t remember the name of the form! 
 
If you know any portion of the name or description you can still find that form using 
Wildcard capabilities. 
 
With the cursor sitting in the Go To field: 



1. Key in a % sign, then BDST and press. 
  

 
 
2. A popup results window will come up showing all forms that end with “BDST”. Typing 
the % sign at the end of a character string will search for forms that begin with that 
string. 
 

 
 
3. Scroll down to find the form you want and then double-click to launch the form. 
 
Wildcards in Banner 
 
Two wildcard characters are used in Banner: the percent sign “%” and an underscore 
“_”. Wildcards are used to fill in unknown characters in a form name or a search 
criterion. The search results returned depends on the number of items that satisfy the 
search criteria. 
 
WILDCARD  FUNCTION  
%  The percent sign wildcard is used when 

one or more consecutive characters are 
unknown. For example, when searching 
for a form, FGI% will result in a list of 
all forms that begin with the letters FGI 
such as FGIBAVL, FGIENCD, FGITRND, 
etc.  

_  The underscore wildcard is used when 
a single character is unknown. For 
example, a search using FGI_AVL 
returns FGIBAVL (this is the only form 
that satisfies the search).  

 
 



The Options Menu: 
 
Allows short-cut navigation to related Banner forms and windows.  Choices depend on 
the form and the block you are currently using – the list reflects other associated forms 
or blocks. 
 
Can be activated by either clicking on the menu item or concurrently pressing the 
Alt key and the letter O (if the option wanted is the first one on the list starting with a 
specific letter, pressing that letter will activate the form or window). 
Items in the list not followed by an object name can also be reached via the tabs across 
the display. 
 

 
 
There are two ways to return to the key block on a form from any associated block. 
Either: 
 
• Use the Rollback icon on the Toolbar (this also “clears” the form) 
 
• Press Shift-F7. 
 
 

 
 
Customizing My Banner 
 
The My Banner feature on the Banner Main Menu is used to “bookmark” frequently 
used Banner forms. Adding forms and/or queries to My Banner eliminates the need to 
navigate through menu paths to access frequently used forms. It also eliminates the 
need to memorize form names or keep a separate written list of frequently accessed 
forms. 
 
Adding a Shortcut to My Banner 
 
The easiest way to create a shortcut in INB is to do it from the actual form you want the 
shortcut for. 
 
1. Open the form you plan on creating a shortcut for 

 



2. Right click any portion of the form that is not an actual field and you will get a 
listing of options. Then select the option to “Add to Personal Menu”. The menu 
listing will disappear if chosen successfully. 

 

 
 
3. Do this for each form you want to have a shortcut. 

 
4. In order for the shortcuts to show up in your My Banner folder, you must exit INB 

and then login again. 
 

5. To see your shortcuts, expand the My Banner folder and your form shortcuts should 
now appear. 

 

 
 



How to Delete Shortcuts from your My Banner folder 
 
Sometimes you may want to clean up your My Banner folder. Removing shortcuts is 
done via the GUAPMNU form. 
 
1. Enter GUAPMNU in the Go To field and hit enter. 
 

 

 
 
All the shortcuts currently showing up in My Banner are listed on the right-side of the 
form. 
 
2. To delete the form, find it on the list in the right-side and double-click on the 

form/object. Double-clicking is required to actually select the form – which will then 
change color (by default it should turn blue). 
 

3. Click the left arrow in the middle of the page and you will notice your selected item 
disappear from the list on the right. 
 

4. Save your changes by clicking on the Save button. Next time you login to INB 
forms/objects deleted will no longer show up in the My Banner folder. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
Appendix A  
 
Banner Function & Keystroke Table  

 
 
 
FUNCTION  

 
MENU OPTION 

 
KEYSTROKE 

 
TOOLBAR ICON 

Record Functions        
Next Record  Record / Next Down Arrow  
Previous Record  Record / Previous Up Arrow  
Clear Record  
Delete Record  

Record / Clear 
Records / Remove 

Shift + F4  

Insert Record  Record / Next F6  
Duplicate Record  Record / Duplicate F4 None 
Save Record  File / Save F10  
Block Functions     
Next Block  Block / Next Ctrl + Page Down  
Previous Block  Block / Previous Ctrl + Page Up  
Roll Back  File / Rollback Shift + F7  
Query Functions     
Enter Query  Query / Enter F7  
Execute Query  Query / Execute F8  
Cancel Query  Query / Cancel Ctrl + q  
Count Query Hits  Query / Count Hits Shift + F2 None 
Miscellaneous     
Next Field  Field / Next Tab None 
Previous Field  Field / Previous Shift + Tab None 
Select  File / Select Shift + F3  
Print  File / Print Shift + F8  
Help  Help / Various 

Selections 
Available 

  

Scroll Up   
Scroll Down  
  

None Page Up 
Page Down 

 

 
Display Navigation 
Window-Go To:  

None F5 None 

Show Keys  Help / Show Keys Ctrl + F1 None 
Exit  File / Exit  Ctrl + q   
 



 

 

Banner Terminology  

Specific terminology is associated with Banner and some terms may have a different 
meaning than what they have in other applications. Below is a list of commonly used 
Banner terms.  

Block – A section of a form that contains a collection of related information. There are 
two (2) primary blocks in a form:  

Key Block – Contains information that determines what is entered or displayed on the 
other parts of the form. This is also the block to start with each time a Banner form is 
opened.  

Information Block – Displays the information based on the data entered in the Key 
Block. This block may consist of a single screen where all the information is displayed or 
it may have multiple screens accessed by tabs.  

Form – An online document (also known as a screen or window). Information can be 
looked up in the database using a form. Forms in Banner have specific names that 
indicate which system and module the form belongs to, as well as the type of form, and 
the function of the form. There are four types of forms in Banner: Application, 
Maintenance, Query, and Inquiry.  

List of Values-LOV(s) – A list of values is a predetermined value for specific fields 
located on the different forms. The list of values depends on which form is currently 
being used. A LOV is a list you can select values from; a value cannot be typed when a 
field has a LOV assigned to it.  

Next Block – An icon on the toolbar that enables a user to move to the next block of 
the form. If the information block has tabs within it, the Next Block key can be used to 
move between tabs.  

Previous Block – An icon on the toolbar that enables a user to move back to the 
previous block in the form. If the information block has tabs the Next Block function can 
be used to move between tabs.  

Query – A query is the process used when searching for information. Using specific 
criteria narrows down the results when the query is executed.  

Rollback – An icon on the toolbar that returns a user to the Key Block and clears the 
data from the form.  

 


